GIS Fundamentals

Lab11: Terrain Analysis

Lab 11: Terrain Analyses
What You’ll Learn: Basic terrain analysis functions, including watershed,
viewshed, and profile processing.
There is a mix of old and new functions used in this lab. We’ll explain the new,
but you are expected to review old labs if needed.
You should read chapter 11 in the GIS Fundamentals textbook before this lab.
Data is in the \Lab11 subdirectory, all in NAD83 UTM zone 15 coordinates,
meters, including driftless, a raster elevation grid, 3m cell size, Z units in meters,
and driftless30, a raster elevation grid, 30m cell size, Z units in meters. A shape
file called viewspot.shp is also used in this lab.
What You’ll Produce: Various hydrologic surfaces, a watershed map, a
viewshed map, and profiles.
Background
Elevation data, also known as terrain data, are import for many kinds of analysis,
and are available in many forms, from many sources and resolutions.
Although the most common use of DEMs is as shaded relief background for
maps, we often are interested in working with terrain data – calculating slopes,
aspects, steepness or slope along profiles, viewsheds, as well as watershed and
other hydrologic functions. The readings and lectures describe some of these
applications, and this set of exercises introduces them.
We will complete two projects here, using the same basic data. The first project
has two parts, first comparing DEM raster data sets from 2 time periods; a 30
meter data set from the USGS and produced in the late 1980s, and a 3 meter
data set from LiDAR data collected about 2006. We then use the LiDAR DEM to
explore profile and viewshed tools.
Our second project focuses on watershed processing, using the ArcGIS
Hydrology tools.
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Project 1: Raster Surfaces, Profiles, and Viewsheds
Start ArcGIS Pro, create a new project, add a Map, add the raster driftless to the
view, and inspect it. Right click on the layer in the TOC and then Properties –
Source tab to inspect the layer properties. What is the cell resolution? What are
the highest and lowest elevation values?
Now add the raster driftless30, and inspect it for resolution, cell size, and values.
Use the Raster Calculator to subtract driftless from driftless30. Inspect the
range of differences in elevation and note where they largest differences tend to
occur.
This illustrates the differences you can encounter with data from the same area.
The driftless layer is a newer version developed from LiDAR data at a higher
vertical and horizontal resolution, while driftless30 is an example of the highest
resolution data available in most areas until the early 2000’s.
Declutter the view by removing the driftless30 DEM and the difference layers
from the map.
Derive the hillshade for driftless (see earlier labs, or search in the geoprocessing
pane).
Specify 25 for the Altitude
and model shadows. Name
the output file something
like hs_drift.
Make the hillshade semitransparent (Layer
Properties→ Display,
then set the transparency
to something like 50%
(Video:
RasterTransparency).

You should get a display
that looks approximately
like the graphic at right.
(minimum-max, gamma=1)

We’ll look at a few tools
that use elevation.
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Viewshed
First, we’ll identify a viewshed, all the areas that are visible from a given point.
Add the viewspot shapefile to your Map.
This shapefile displays a single point, in the
bottom left portion of the driftless DEM.
Open the Viewshed 2 tool, either by
searching for it in the geoprocessing pane or
from Tools – Toolboxes – 3D Analyst –
Visibility – Viewshed 2.

Specify the driftless DEM as the input raster,
the viewspot and the observer features, and
an Observer offset of 2 meters:

Video: Viewshed&LineofSight

Your output should appear as below, with the
cells visible from the viewpoint here colored
in orange:
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Visibility on a Line of Sight
Sometimes you wish to know the visibility between two locations, e.g., when
placing a repeater for a radio signal, or a Add the shapefile Sightline.shp to your
Map.
Specify the Line of Sight tool, either by searching for it in the geoprocessing pane
or from Tools – Toolboxes – 3D Analyst – Visibility – Line of Sight
Specify the driftless DEM as the input
surface
The sightline polyline as the input line
features
and something like VisibilityLine for the
output feature class
Leave the other options blank, they are to
add or record obstruction locations.
Run, and if it isn’t added automatically,
add the output feature class to your Map.

This should display a sight line
over the DEM, like the one
shown on the right. I’ve
increased the line thickness a bit
for greater visibility.
The green sections are visible
From the starting point on the
left, and the red sections are
hidden by intervening terrain.
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Profile Along a Path
Sometimes you wish to measure or plot the steepness along a path or ski trail,
e.g., along a road or potential travel segment.
To do this we must first add the elevation information to the intended path. We
can then chart the path.
Add the layer roads.shp to your Map.
Open the tool Interpolate Shape,
either by searching for it in the
geoprocessing pane or from
Tools – Toolboxes – 3D Analyst
– Functional Surface –
Interpolate Shape
Specify the drifless DEM as the
Input Surface,
Set roads as the Input Features,
Name the Output Feature
something appropriate,
Set the sampling distance to
between 3 and 6,
Set Method to Bilinear,
Leave the other features as their
defaults, and Run the tool.
On finishing, the tool should add
the interpolated shape to your
map. It should also have added
the elevations to the line data, posting them at the sampling distance you chose.
You can create profile plot from this new output feature you created, which plots
the vertical distance you move up or down against the horizontal distance
traveled on each segment.
(Video: Profile)
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Right click on the
Output Features in
the TOC, and from
the dropdown select
Create Chart, then
Profile Graph

The profile graph shows
the profile line trajectory,
but in a side view, with
elevations on the vertical
axis and horizontal
distance on the horizontal
axis (see right).
Inspect the profile graph,
and then the DEM, and
corroborate the changes in
steepness along the road
path. Note the left-most
point on the graph
corresponds to the road
end at the bottom of the
Map.
Also note you can change
properties of the graph via
a Properties tab (arrow above), including the overall and axis titles, and units.
You may export the graph to an image file, either a jpg or png, using the tab next
to the properties tab (right arrow, above). You specify the output by typing the
entire name, including the extension, e.g., profile.jpg for a jpeg file.
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Create a Layout that includes your Map, legend, north arrow, name, title, and
usual other elements.
Make sure you include the following layers in your Layout:
Viewspot and viewshed
Sightline, with visibility/hidden segments shown in different colors
The roads, DEM, and semi-transparent hillshade,
Your profile graph, as a separate element outside of your Map and Legend
You may add the profile plot to
your layout by selecting it in
the Insert group, next to the
scalebar and legend options,
then selecting the profile you
created and named (see
figure).
After adding the profile plot to your layout, double check that it has appeared in
the layout view.

Create a layout like that shown below, and export a PDF to turn in.
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Project 2: Watershed Functions
Save your project, above, if you haven’t done so already. Then, open a new
Map, either in the same project, or in a new one, and add the driftless DEM.
We’ll be using ArcToolbox for this new project but be forewarned – these tools
are buggy. You are best bet is to start early, follow the instructions carefully,
save often, and if it doesn’t work, close ArcGIS and restart from the beginning
(meaning create a new project, and repeat the steps). If this doesn’t work,
please contact one of the instructors for help – no sense in banging your head
against a wall. (see Video: Watershed).
In the Analysis tab open
Tools→Toolboxes→Spatial Analyst Tools –
Hydrology. This should display the tools shown at
the right:
We’ll be applying them in the following order:
(The order is important.)
Fill
Flow Direction
Flow Accumulation
Snap Pour Point (on a point feature we’ll create)
Watershed
Let get started, we use the Fill command to fill in pits
in the DEM. As described in chapter 11 of GIS
Fundamentals, pits are local depressions along which
a stream would be expected to flow. These
depressions may be real, or they may be due to
errors in the data. However, a DEM is a
representation of a waterless terrain surface, (the flow
algorithms used here are programmed on this basis). So, local pits or flat areas
may “trap” our route-finding when we are trying to identify downhill directions.
The simplest of watershed processing routines begins by simply filling the pits.
More sophisticated ones may fill the pits, and “burn in” a stream line, along which
the DEM is lowered after filling to maintain a downstream flow. We will use the
simplest Fill approach.
Apply the Fill tool from the Hydrology toolbox. Specify the driftless DEM as
input, and something like filled_dem for the output name. Don’t bother with the Z
limit, here and in the subsequent tasks, and Run the tool. In more a sophisticated
analysis, you would specify a small Z limit, with a value that depends on your
analytical needs. If this doesn’t fill your DEM pits, then you must re-evaluate your
goals, processing flow, and data sources. In this instance, we’re providing a
well-behaved DEM, so you can fill all of them.
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After a minute, the filled data
set should be automatically
added to your view. Subtract,
via the Raster Calculator, the
driftless DEM from your
filled_dem, and display the
calculation. Change the color
display and Display
Background Value as dark
blue. Notice the location and
range of the fills; it should look
something like shown on the
right.
Remove the difference raster to avoid confusion in later steps
Now, apply the Flow Direction tool, using the filled_dem as your input, and
specifying a flow direction output data layer; name the output f_direction. Check
the box “flow all edge cells to flow outward”, use the D8 method, and don’t
specify a drop raster.
As noted in the textbook, this flow direction layer will contain a
direction coding, with a set of numbers that define the cardinal and
sub-cardinal direction, something like the figure to the right. The
number 1 in a cell means water flows due east, 128 indicates
northeast, 64 water flows north, and so on. This is a discreet categorization, all
the water flows from a cell to an
adjacent cell in only one of 8 directions.
This method is known as the D8 flow
direction, to distinguish it from methods
that can send a portion of the water
from a cell to multiple neighboring cells.
Your output from the flow direction tool
should look something like the figure to
the right, and the symbols should show
8 values from 1 to 128, corresponding
to flow direction.

Now apply the Flow Accumulation tool from ArcToolbox. This finds the highest
points and accumulates the area (or number of cells) downhill, according to the
flow direction.
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Specify the input as
f_direction raster you
just created, name the
flow accumulation
raster something like
f_accum, ignore the
weight raster, and
specify an output data
type of Float and leave
the Input flow direction
type as D8.
This should generate
a layer that displays
like the graphic at
right. If you look
closely, you will see
some narrow, perhaps intermittent white lines in a dark background.
Notice the maximum and minimum value for the data layer, they will be
something like 1.63 * 10^6 and 0.
These numbers are the cells that drain to any given cell. For example, a cell with
a value of 12,847 receives water from that many cells. Since these cells are 3 m
by 3 m, each cell counts for 9 square meters, and there are about 111,000 cells
per square kilometer.
We may use this flow accumulation grid to approximate where streams will be
found on the surface, and to determine outlet points for watersheds.
In any given small region and geology, there is usually a rough correspondence
between drainage area, here measured with flow accumulation, and stream
initiation. For example, once a drainage area of 0.45 square kilometers is
reached, a stream may form. This would be 0.45 km2 * 1,000,000 m 2/km2 / 9
m2/cell, or about 50,000 cells. So, if we symbolize the flow accumulation layer so
all cells above 50,000 are blue, and all equal or below is no color, we will get an
approximate idea of where the streams will be found (this threshold is made for
this exercise but is probably not too far off). (video: FAC2Streams; note: two
different approaches are described in this video. You only need to do the first approach, the reclassification
of the symbology now, but at the end of this lab you will do the second approach, reclassification of the
raster layer to a new raster layer and then exporting that new raster layer to a polygon.)
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You may apply the
symbolization by
reclassifying the flow
accumulation layer into
two classes, and setting
the lower threshold to
50,000, the upper
threshold to the
maximum value, as
described in previous
labs.

We must apply a couple of more steps to
define our watersheds. First you must
create an empty point layer in the same
coordinate system as the driftless DEM,
named something like outlet. Refer to
previous labs if you’re unclear how to do
this; Lab 3;).
Then we must digitize a watershed outlet
point. Add the new empty outlet data
class to the make it the active editing
target and display the DEM with the recolored flow
accumulation grid over it.
Zoom into the southwest quadrant, so that your
view looks like that at right. Digitize a point near the
location shown below, along the stream near the
outlet to the largest watershed in the DEM.
Remember, the figure at the right is zoomed to
about ¼ of the DEM extent. You’ll want to zoom in
much closer to digitize the point, so you can place it near the center of one of the
stream cells.
A zoom something like that shown in the bottom image is more appropriate: Start
Editing, add your point, then save your edits and stop editing. Zooming in as far
as you can helps you make sure your digitized outlet point is exactly on a stream
cell.
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Now apply the Tools→Toolboxes→Spatial Analyst Tools Hydrology→Snap
Pour Point tool.
•

Specify Outlet as your input raster or feature pour point dataset,

•

any pour point field, (OBJECTID is fine)

•

the flow accumulation raster you created earlier

•

a new output raster to contain your raster pour point, name it something
SnapPour

•

an appropriate snap distance, something like 3 to 9 (about 1 to 3 cells).

This should create a raster with a single cell for a value, near your digitized
outlet.
Now, run the Hydrology→Watershed tool,
specifying your flow direction raster, your just
created raster pour point layer, leaving the
pour point field as “Value”, and specifying an
appropriately named output watershed, like
watershed.
This should create a watershed raster.
Use symbology, unique values to add a color
and make the watershed raster layer
semitransparent (see below)
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If you want, you can export it the raster version of
the watershed to a polygon by Tools→
Toolbox→Conversion Tools→From
Raster→Raster to Polylgon. Changed the color
and made the watershed polygon 50%
transparent.

We want to reclassify and then export the flow
accumulation raster, if we don’t we will only have
cells that are
streams and
we can’t make
the width of the stream larger and more
visible on our Layout. We’ll use a threshold
of 50,000 cells, as described in the section
above. In case you’ve forgotten, a reclassify
is most easily done with the Reclassify tool
described in an earlier lab, found at Spatial
Analyst Tools→Reclass→Reclassify.
You’ll want to set values at or above 50,000
to 1, and below 50,000 to NoData. Name the
output something like rast_streams.

Now convert the reclassified streams from a
raster to vectors, use Tools→
Toolbox→Conversion Tools→From
Raster→Raster to Polyline
Name the output something like
Derived_Streams.
Select Background value as NODATA and
Simplify polylines.
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Create a layout displaying the driftless DEM, Watershed, Outlet and
Derived_Streams with all the usual elements, export it as a .pdf. Remember to
include your name.
Remember to turn in:
1) a Visibility & Elevation Profiles map
2) a Watershed map
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