Lab 1: Introduction to ArcGIS Pro

What You’ll Learn:
- Start ArcGIS Pro
- Create a new map
- Add data layers
- Pan and zoom
- Change data symbology
- Change display properties
- Select data
- Measure distances
- Create map layouts
- Add legends, titles, North arrows, and other elements
- Print a map to a PDF

Data for this exercise (and all future exercises) is found in the numbered lab folder on the class "share" directory: either, L:\FRNM3131 or L:\FNRM5131. It is best if you transfer/copy the ENTIRE contents of the shared directory each week to your H:\ folder and then copy the H:\ folder to your Desktop for your active workspace; remembering to copy your Desktop working copy back to the H:\ for safekeeping. The class “shared” directories are “read only”. The data for each lab is also on the class website/”lab page” for each weekly lab. The data files on the website are “compressed” and must be “extracted” to be used. Quick Start material on the class website/”lab page” provides for more information. This week’s data is found in L:\FNRM3131\Lab1

What You’ll Produce: Four maps: one of lakes and roads, one of wetlands, a third map of the Cloquet Forestry Center, and a fourth map of the North Shore.

Background: This is the first in a series of introductory exercises for ArcGIS Pro. These are practical skills that complement the theory and practice of GIS described in the textbook “GIS Fundamentals: A First Text on Geographic Information Systems”, by Paul Bolstad.

We assume you are using ArcGIS Pro running on the virtual desktop (using the Citrix Receiver and the CFANS Desktop) or a UMN lab computer. These exercises were developed with ArcGIS Pro version 2.0.
Each lab assumes you have a copy of the needed data files, and know how to copy them to a location that is efficient for you to use. If not, see the handouts and videos on lab mechanics on the course lab page.

Where you open and store your data for ArcGIS Pro makes a huge difference in performance speed. All work should be on the Citrix CFANS Desktop computer or in the H:\ directory. Any projects or files accessed on USB drives, local disk drives or Google Drives will be very slow and may crash.

**Part 1: Starting ArcGIS Pro, adding data and creating your first map**
First, find the ArcGIS Pro icon, shown to the right. The icon is often located as a desktop or taskbar shortcut, or in an ArcGIS folder.

In Windows 7 or 10 it may often by found by left clicking on the Start button in the lower left of the screen and selecting Programs → ArcGIS → ArcGISPro. *(Video: Intro2ArcPro)*

Double left click on the ArcGIS Pro icon, and be patient while a start banner displays. Depending on your startup option you may or may not see the ArcGIS Pro – start screen *(shown below left)*. Left click in the area on the right *(below)* to create a new, blank project.

This will open the main ArcGIS Pro window, similar to that displayed here. You create a new project by clicking on one of the templates listed on the right side of the screen:

Here, choose a Blank project, and it will ask you to specify the project name. Here I specified the name Proj1, in the directory named Lab1 on the H:\Home\\(\text{your id}\). You can
uncheck the box for “create new folder” so as to not create many unnecessary folders within.

```
Create a New Project

Name          Proj1
Location      C:\Desktop:\Lab1

Create a new folder for this project

OK   Cancel
```

**Note** that the Project is stored in an .aprx file, in the directory you specified, along with a default geodatabase for scratch work and created layers. We’ll describe geodatabases towards the end of this exercise. You can’t rename a project once you’ve created it, but you can save it to a new file. It is good practice to store your main data and projects in the same directory, and to use something like “Proj” as part of the project name so that you can easily recognize it.

Left click on O.K., and this will display the main window, shown below. It contains quite a few components, including actions along the top, a table of contents on the left, a catalog on the right, and various tabs in the middle section. The tools available along the top change depending on the active tab. In the figure below, the Insert tab is active, noted by the highlighting and a light blue bar above the label (see the arrow in the figure below)
Click on the **Analysis**, **View**, **Home**, and **Imagery** tabs, and note the tools change.

We'll cover these in future labs, today we'll focus on adding and displaying data, so click back on the **Insert** tab.

Left click on the **New Map**, near the upper left corner of the window (see the figure, at right).

This will open a new map tab in the central pane, and in most cases display a default topographic and hillshade map, also listing them in the table of contents to the left:
Notice that it also activates the Map tab near along the top of the window, with the map tools displayed. If you don’t see a tool you expect across the top, it is likely under a different tab.

You can pan about the map by left clicking and hold-dragging on the map pane and zoom by using the “four in” and “four out” arrows in the navigate tools (see red arrow and box, above). Mice with a scroll wheel may be set up so a roll forward zooms in, and a roll backward zooms out, but this depends on the specific configuration.

The globe in the Navigate tools will zoom to the full extent of the layers, and the right and left pointing blue arrows will zoom forward or backward through your zoom history.

Click the check boxes next to the World Topographic and World Hillshade layers, and note they toggle the layers’ visibility on and off.
Delete the World layers from the map. Do this by first left clicking on a layer, surrounding it with a blue box, and then right clicking on the blue box, revealing a drop-down menu with various options:

Clicking on remove will delete a layer from the project.

Do this with the two World layers.

Now to add some data.

Click on the Add Data tool, found along the top in the Map tab tools:

This will display a directory and file system.

Navigate to where you stored your lab data and select the shapefiles named lakes.shp and roads.shp.

This will add this data layer to your map.

The layer data are displayed in the Map pane, and data names are listed in the table of contents pane on the left.
There are also useful tools along the bottom of the main window, highlighted by the red box and arrows below.

The leftmost red arrow points to the box that displays the nominal scale. You can select one via the dropdown in the box, or by typing one in directly. The second arrow shows the current cursor coordinates when it is over the map pane. The right two red arrows indicate tab selectors for the right-hand pane. Here there is a Catalog and a Symbology tab available. Note: These toolbars COULD be located on the right side to the screen instead of the bottom. Toolbars are “moveable”.
Changing Layer Symbology
(see the video Symbols, in the course lab resources)
We can customize a layer’s appearance. Left click on a Symbology tab (rightmost arrow above), then on the roads layer. The right-sided project pane should look something like the figure at right.

The Symbology box is currently set to single symbol, you can view options by clicking on the dropdown triangle at the right side of the box (blue arrow in graphic).

We’ll leave it single symbol for now.

You can change the line color and weight by double left clicking on the current symbol (aka the green line, indicated by the red arrow in graphic).

This will open another window (shown at right).

You can scroll and pick one of the symbols in the Gallery, using the scroll arrows/tabs on the right of the pick grid.
If you wish to use a symbology that isn’t in the provided set, you can directly access the symbol properties by clicking on the Properties option (see arrow at right).

Although there are many options you can set, for now just use the Color and Line width options to specify black roads, 1 pt wide.

Repeat this process for the lakes layer, specifying a light blue interior, and darker blue boundary for the lakes.

Remember that you need to select the layer, then activate the Symbology tab, then your map should look something like the image below.
Create a Layout, Export a Map

We often wish to create a map depicting our data, plus information such as a title, legend, north arrow, and a scale bar.

To do this here, first activate the Insert tab, then left click on New Layout to display a set of page options:

(Video: Layout&NorthArrow, note, the videos use different data than yours here, but the techniques are the same).

Since our data are wider than tall, we’ll choose the Landscape Letter option.

The layout is empty at first. We add a map two ways, first by opening the Catalog tab on the right (remember, bottom right), then the Maps list, then drag and dropping a map onto the layout:
You can also add a map by opening the Map Frame near the upper left when the Insert tab is active, and selecting a map from the displayed list:

Don’t add the map a second time. If you do, you can select one of the copies either in the table of contents, or on the layout, and right click over the selected map, then choose ‘delete’ from the dropdown menu.

We add the most common layout elements using the options displayed in the middle area of the Insert tab panel.

These include a North Arrow, a Scale Bar, a Legend, and descriptive text:
These elements are accessed via double clicking on the tool for the default, or clicking on a dropdown arrow near the lower right of the icon to display a pick list of options, e.g., for the North Arrow (right graphic):

Double clicking on an option drops it onto the layout, with handles to resize. You can click-hold-drag on any element to reposition.

Add a North Arrow, and resize/position to your liking.

Add a Scale Bar, using the pick list, and a process similar to that of the North Arrow.

Formatting a scale bar is a bit more complex than a north arrow. *(Video: ScaleBar)*

You can change the text size for labels using the Element pane, which shows up on the right when you click on the scale bar to select it.

This lets you change the Appearance (font and size), position, rotation, and other properties for the scale bar text.
If you wish to change the number and units of the number of divisions, units, and label placement, you must first click on a scale bar to select it, then click on the **Design tab**, near the right center of the top menu options:

This lets you specify all the important characteristics of your scale bar. The primary criteria are readability and clarity, and the default is often placed with too small a font, or odd break values.

Most maps need a legend; added here with a tool found to the right of the North Arrow and Scale Bar tools under the Insert tab: *(Video: Legend&Text)*

Clicking on the Legend tool activates the cursor as a crosshair, and allows you to click-drag on the layout to place a legend.
This opens an element tab - on the right side of the main window - that allows you to specify the size and other characteristics of the legend when the Legend Item is selected, and it appears blue (see right). Font size and other text appearance options are made available when you click on “Text Symbol” and it appears blue.

Legend items are included for all the layers displayed in the map.

Make sure your map has a title (add text from the Insert tab), your name, legend, north arrow, and scale bar. These elements should be reasonable and well-positioned.

Your layout should look something like the image at right, but you don’t have to match it exactly. Just make sure to include the required elements, listed above. We encourage you to use different fonts, colors, north arrow, and scale bar, or at least peruse what are available.
Export a PDF file. Select the Share tab, at the far right of the upper tabs, and click on Layout Export (red arrow):

(video: Export Map)

This will open a menu that lets you select the location and file format. You will be turning in pdf files, with at least a 150-dpi setting. Other settings are appropriate for other uses, e.g., jpeg or other graphic formats to include in reports, or .ai for further cartographic enhancements in Adobe Illustrator. For this class the default format is pdf; almost all our labs require at least one pdf be turned in.

Save the pdf of your map to Desktop\Lab1 and later your will copy the entire Desktop\Lab1 folder to H:\ for safekeeping; finally (after all your Lab 1 work is complete) you submit your PDF’s via Canvas.

Saving Your Project
You should save your project frequently while working, in case you have a system failure or accidently delete project elements. Since ArcGIS Pro is somewhat buggy in these early releases, it may save you much time and grief.

(See image on next page)
You save a project by clicking on the Project tab, in blue, near the upper left margin of the main window.

This opens a new window, in which you can Save to your current location, hopefully \Lab1 or Save As to \Lab1. We recommend you include something like “proj” in the name for ease in identification, e.g., “Hugo_proj” as this will reduce confusion between the various kinds of files you are creating, at least until you become experienced. Remember to copy your \Lab1 folder from the Desktop to H:\ before you leave your computer.

Any projects or data saved on the desktop will disappear when you logout. You must save your work to a location that is permanent, like your H:\.
Arrow returns to the project view

Save progress or Save As to a new project
Symbolize Categories (Video: Unique Symbols)

Save and close your previous project, then create a new project named something like `Wetlands_proj` and add the layer “wet_land.shp” from the data directory. This layer shows polygons for wetlands near Hugo, Minnesota.

Click on the symbology tab in the lower right:
Then click on the Symbology window caret to reveal a drop down window, and click to select Unique Values:

Specify WETLAND_TY as the value field; it adds a different symbol for each unique value found in the specified Value field:
The assigned color scheme is displayed for each category (see at right) you often have a large number of categories and want to change colors for some of them.

Let’s assign the lakes a blue color, and since the U value (which means Uplands) is such a large part of the map let’s make it blank to make the map more readable.

Click on the color box next to the L value.

This displays a Format Polygon Symbol option, either as a Gallery of choices (left, below), or a Properties (right, below).
Note that when the Gallery window is selected the ‘Gallery’ text appears in blue. To switch to the Properties options, just click on the Properties label and it will be displayed in blue as shown in above right.

To assign from the Gallery, simply scroll and then click on a patch in the set of available choices.

To assign from the Properties view, click on the caret to the right of the Color or Outline Color and choose a color. You can also click on the Outline Width to pick, or type in, a width.

For now, we’ll choose a light blue lake color, and a darker blue outline for the lakes and keep the outline width as is.

Click Apply near the bottom of the window to apply your choices.
Now let’s assign no color to the uplands (U symbol).

Click on the back arrow near the top-right of the Symbology window in the Gallery/Properties view, and this will re-display the color assignment scheme.

Scroll down to display the U color, and click on the color patch:
Select the Properties option, and then assign a light tan color to the Color, and No Color to the Outline Color, using the carets to display the color charts:
Your Map window should look something like the figure to the right. Don’t worry if your wetlands polygons are a different color, just make sure the lakes and uplands are assigned correctly.

Create a layout, adding the Map, a Title, Legend, Scale Bar, North Arrow and your name/date.

Practice selecting the map, title, legend and resizing each item.

Export this map to a PDF, named something like “Wetlands,” to turn in.

Save the project with your data.

Close and start a new project called something like “Cloq_forest” and continue with the directions below.
More About Maps
Most projects in ArcGIS Pro include a working area called a Map. You added one in the first part of this lab, and you may add several into a single project. It is perhaps easiest to think of these maps as analogous to desktops, onto which you place data layers. Just as you may have several desks in a room, you may have several Maps in an ArcGIS Pro project.

To carry this analogy further, you may place different data on each “desktop,” or Map. You may also display a different area, use different symbology, and different coordinate systems for each Map.

Setting Map Properties
After we’ve added a Map to a project, we may alter its properties. We do this by left clicking on a Map tab - displayed along the top of the central window - to make it our target, then right clicking over the selected map.

This opens a map properties window, with several options:

1) Right clicking over an active Map in the Table of Contents drops down a menu; 2) clicking on the last item, Properties, allows you to set options for the map, including units, extent, and the coordinate system.

Clicking through the options, you can see that the General tab allows you to change the Map name, measure or layer units, the units displayed on the bottom for coordinate location, a scale, background color, and other general properties.
Other options let you specify the Map extent, where it will show or work with data, the displayed coordinate system, and other features that will make more sense later in this course.

For now, change the Map’s name to Cloquet, and just note that you can set other Map properties, which we’ll revisit later.

**Setting the Layer Order**
Add the following layers from the data provided (remember, activate the Map tab along the top of the main ArcGIS Pro window, then use the Add Data icon):

- `40_corners`
- `Cl_roads` (NOTE: “CL_ROADS” NOT “ROADS”)
- `Streams`
- `Iverson_drg`

Notice that the table of contents lists the point data layer on the top, then the two line data layers (roads and streams), then the raster data layer (`Iverson_drg`).

We can manually shift data set order in the layer stack.

Left click on the `Iverson_drg` layer and hold the mouse button down. While holding down the mouse button, drag the layer toward the top of the stack.

As you do a black line will show the new position in the layer stack. Move this layer to the top of the stack and release the button, dropping the layer.

The rearranged layers now look different because the `Iverson_drg` covers up the other three layers.

Drag the `Iverson_drg` layer back to the bottom of the stack.

To widen or narrow the table of contents (TOC) pane, left click and hold on the vertical line between the TOC and the data view, and a two-arrowed line will appear. Stretch the line to the right, widening the TOC to see all the layer title information. (e.g. shown at right)

You can change the displayed names of the data sets (the file name does not change) by:

- selecting the layer by right clicking on the name, then
- selecting **Properties → General** tab
- entering text in the Name textbox
- left clicking **OK**
- OR try double left clicking on the current layer name which will then allow you to edit the layer name.
Pan, zoom, re-arrange layers, and apply symbology until your map appears similar to the image below. Make sure the streams are dark blue, the roads black, and the widths of both are 1.5 pts.
Measuring Distances and Areas
Zoom to the Gravel Pit and Lookout Tower, panning/zooming so that both just fit in the window (see figure at right).

These are in sections 29 and 32, south of the points in the 40_corners data set, and southwest of the Cloquet airport. Looking for the distinctive “wiggly W” of road in the center-right portion of the road network may help.

*(Video: Measure Tool)*
While having the map tab open find the **Measure Distance** tool along the top of the main window:

Single left click on the caret at the bottom of the icon, then select the function you wish to apply with the measure tool, here, measuring distance.

Notice this changes the shape of your cursor when on the map to an “L” ruler and a cross hairs.

You measure distance by first placing the cross hairs on a point, left clicking, then moving to another point, and left clicking again.

A box in the upper left corner will display the cumulative distance.
You end the distance measurement by a quick double clicking at an end point.

The example at right shows a distance measured from the Gravel Pit to the nearest main road as about 2,308 feet.

You can change the measurement units, e.g., from feet to miles, via the Options box.

You can reset the starting point via the tan “eraser” icon to the right of the options. You can also copy the result to the computer’s copy cache using the “notepad” icon in between.

Use the measure tool to estimate the distance between the Gravel Pit and the Lookout Tower, in feet.

**Write this number down**, as you will need to enter it using canvas, as part of the credit for this week’s lab.

Measure the area of one of the sections - they are numbered, lightly drawn red-dashed squares. Measure the area in square miles and **write it down for later entry**.

To close the Measure tool, click on the Explore icon in upper left under Maps tab.
Pan and zoom your map to cover an area similar to the figure shown to the right.

Now compose and export another PDF map.

Add a Layout, as described earlier, and use the Insert tab to add a Title, North Arrow, and Scale Bar.

Remember, you can rearrange elements in the layout by left clicking on them and then either clicking in the center and dragging to reposition, or click on the edge of the boxes, hold, and drag to resize.
Make your map similar to the figure below.

**NOTE:** Do not include the Iverson_drg in your legend.

You can hide the legend entry by unchecking the corresponding box in the table of contents (right):

Export this map as a pdf.
Multiple Maps in One Document

We often wish to have multiple maps displayed on a graphic or page, for example, with an inset map that shows the general location for an area displayed in greater detail. We’ll create such a map in learning the rudiments of layout styling.

First, save and close the previous project, create a new one, named something like “CloqProj,” add a Map, and add the Iverson_drg and the vegetation.shp layer to the map.

Symbolize the vegetation.shp layer so that both the outline and the fill for the polygons are the same neutral gray, so it looks like the figure to the right:

If you don’t remember how to symbolize, refer to the earlier sections of this lab (pg. 18).

Now add a second Map to the project (remember, Insert, then New Map). Remove both world maps.

Add the vegetation.shp data to that map and make it have a tan fill and a black outline, similar to the figure below:
Now add a new Layout to your project.

Drag both the Maps to the Layout. It is perhaps easiest to activate the Catalog tab which will make it appear as a right-side panel of the main window (remember the catalog tab is near the bottom and to the right), expand the Maps marker, and drag the Maps onto the layout.

Notice that both maps appear in the Table of Contents - the leftmost panel in the main window - originally named something like Main Map and Map Frame (as shown below).

You can activate a map in the Layout by clicking on it, which will place the grab squares on the Map margin, and highlight the Map in the Table of Contents:

If you double click on the highlighted Map in the TOC, it will open a Format Map Frame tab in the main panel on the far right (see graphic at right), and you can change some of the Map Frame properties.

Change the name to “Inset.”
Note that this also highlights the Map Frame Formatting tool in the main ribbon across the top (arrow below):

You may further format the Map Frame by clicking first on format under Map Frame, then selecting elements in the ribbon,

and then selecting elements in the drop-down that appears at the left.
For example, to delete the border, select the Border element and set the line color to “No color”
You often want to add graphic elements to a map, in addition to the North Arrow, Legend, and Scale Bars we've added before.

When you activate the main Insert tab, there is a set of graphics tools towards the right side.

For example, I can click on the rectangle, and select it from the dropdown list (see at right).

I can then click and drag on the Layout window to draw a rectangle.

Typically, the rectangle is assigned a default color. If I wish to place a border around all my elements, or to set color to clear or no color I can do so by changing the properties of a drawn object. First clicking on the rectangle to select it (handles will then display on the object), and then click on the Format tab (here Rectangle format shown below) near the top of the main ArcGIS Pro window:

I can then change the Fill and other properties, for example, here making it transparent.
In can also insert lines, points, or images. As an example, we often wish to draw lines, with arrows, here to show how the inset corresponds to the main map, as to the right:

I can add lines by activating the Insert tab, then selecting Line in the graphic elements via the dropdown, and then drawing lines with the desired start and endpoints on the Layout.

If I want to add arrowheads, I must first click on the line to select it (handles will appear when selected), and as earlier, a Line Format tab will appear along the top toolbar. I can click on this to display line formatting options.

Note that if a rectangle or graphic element is above the line, e.g., the transparent one we created, I may not be able to select the line below it. If this is the case, just drag the rectangle aside, and then click to select the line.

Once selected, and I click on Format in the Line Format tab to activate, a small dropdown menu will appear on the left:
I can click on the bottom caret to display a fuller set of options, and navigate and select the Arrow End option for my line:
Create a layout similar to the one below. Be sure to include the title, your name, a legend, scale bar, and north arrow.

Also, be sure to include the bounding rectangle, and the arrows from the inset to the larger-scale vegetation data.

Export a PDF, and turn this in.

Example of pdf map to turn in:
Part 2: ArcGIS Pro Projects, Shapefiles, and GeoDatabases

You may wonder about the data layers you have used for your maps, e.g., Lakes, Roads, and wet_land. These layers are shapefiles, an early format defined by ESRI for storing spatial data, and now a common standard for distributing and saving spatial layers.

A “shapefile” is actually a cluster of files. You can see this below. On the left is the window that displays when you add data in ArcGIS Pro. It shows just one entry for the lakes.shp layer. However, if we Windows File Explorer to display the same directory (below right), we can see several files with the name lakes, each with different extensions. In addition to the .shp, there is a .dbf, .prj, .shx, and others. A complete shapefile is made up of several files, at a minimum a .shp, .shx, and .dbf files. If you ever copy shapefiles using File Explorer or another generic file management tool, you need to copy ALL THE FILES, NOT JUST THE .SHP FILE. Otherwise, your copy will likely be incomplete, and useless.

ESRI also has another, newer file storage system, called a Geodatabase. This usually stores a cluster of files that are related by geography, or type, or some other criteria. It is a bit complicated, and takes some time to set up and interpret, and has both advantages and disadvantages relative to shapefiles. Since much data are stored and distributed as geodatabases, you should be familiar with them if you are going to use ArcGIS.
Geodatabases are great for organizing data you will often use together, for data sets stored as tiles, or for complex mixes of data. You can store rasters, vectors, points, polygons, and topology all together in geodatabases, and you can specify a common coordinate system, extent, and other characteristics for sub-components of a geodatabase.

A geodatabase appears as a directory or folder to file explorer, and has a .gdb extension. If you look inside the directory, it has a number of component files. You should NOT copy, delete, or edit these component files with tools other than ArcGIS Pro, as it will likely corrupt your geodatabase and render it useless.

A geodatabase usually contains something called a **Feature Dataset**. In ESRI’s parlance, a Feature Dataset is a collection of related spatial data, usually data layers and other geometric constructs. You can have several feature datasets in your geodatabase. You may want to hold clusters of data together, for example, data layers on river locations, lakes along those rivers, and dams associated with each lake. These layers are called **Feature Classes**. It is a bit convoluted, and takes some getting used to, but since all ESRI’s documentation uses these conventions, you should be familiar with them. Remember, the geodatabase is the overall container, a feature dataset is a sub-container of data, and a feature class is a layer of data.

Thus, the lake, road, and wetlands data we have been working with could be stored as Feature Classes, in a Feature Dataset, and additional tables and network connections may also be stored in the feature dataset.

You don’t have to store a feature class in a feature dataset, but it is still rather cumbersome if you have a single layer you wish to treat and store separately, because you have to create a geodatabase, then a feature class, so some folks use shapefiles for single layers.

Exit from ArcGIS Pro, and restart it.
Create a new project, stored in the Lab1 directory (with the rest of your data for this week’s work), and name it `lab1_gdp_proj` (where gdp is my shorthand for geodatabase practice):

As before, I include proj in the name just to remind myself that it is a project.
I also specify I want to create a new directory (check box, image above). I can use Windows Explorer or the Mac Finder to verify the new folder/directory is created, within my Lab1 folder/directory:

I can then look inside the lab1_gdp_proj, again using Windows File Explorer, and see there is a project with the .aprx extension, and a geodatabase folder/directory with the .gdb extension, and a .tbx file, all with the same first part name, lab1_gdp_proj. (Right)

The geodatabase (top in the list) is the default location for new data layers and temporary data layers.

The .aprx project file (middle in the list, with a map/colored folder) is an organizing file with instructions on how you display your data, and where to find the data. It doesn’t hold any data, just the instructions on what to display, and how.

The .tbx file (last in the list, bent-eared paper icon) is a toolbox, a container for any tools you might create associated with the project.
I can look at the current working directory and geodatabases through the Catalog Pane, found via the View tab:

The catalog pane is usually shown by default on the right-hand side of the main window, but may be hidden below another tab, so you may use View-Catalog Pane, or the tabs on the bottom right of the main window to display.

The Catalog lets you inspect the Databases in your current project (lower arrow, figure above).

You can create and add a new geodatabase by right clicking on the databases icon,

and then left clicking on New File Geodatabase from the dropdown menu:
This should display a menu to create a new database. Set the directory to where you have stored your current project (in our example, Lab1), and create a new geodatabase, named something like test_gdb_1:

This may take a bit of time, be patient.

A geodatabase is usually empty when first created. We can import data directly into one.

Right click on the test_gdb_1.gdb geodatabase (in catalog tab under databases), and select Import – Feature Class…
This will open a Geoprocessing tab:

We need to specify the input features. Click on the folder icon to the right of the Input Features slot, navigate to your data directory (here, Lab1), and specify the lakes.shp layer as your Input Features.

Set test_gdb_1.gdb as your output location.

Name the Output Feature Class Lakes_imp, or something similar.

Ignore the rest of the parameters lower down, these are for advanced control during imports, and the defaults suit us here.

When you click Run at the lower right, a processing progress bar should appear, and eventually, a message that the process completed successfully.

You just copied the lakes.shp data into your geodatabase.

Now also import the roads.shp layer to your geodatabase.
You’ve just created a copy of all the data in the Lakes and Roads shapefiles, as Feature Classes in the test_gdb_1.gdb geodatabase.

You can verify the new layers are there by

1) clicking on the Catalog tab near the bottom of the Catalog panel (right side of the main window, at the bottom), and then
2) looking at the drop-down list under Databases – test_gdb_1.gdb, for your two imported layers.
We mentioned that you may also create something called a Feature Dataset, and place Feature Classes within this Feature Dataset.

While the naming convention is rather confusing, just remember that a Feature Class is a layer of information, e.g., the polygons that define a set of counties, or the lines that define a set of rivers. On the other hand, a Feature Dataset is a container for the collection of data layers, all with the same coordinate system, that you wish to store together.

Right click on the test_gdb_1.gdb geodatabase and select New – Feature Dataset.

Note that this will open a geoprocessing window (see below), that asks you to specify:

1) The geodatabase where you will store your new collection of data,

2) The Feature Dataset name, and

3) The coordinate system.

We’ll learn about coordinate systems next week, but for now just understand that like we can measure distance in centimeters or inches, we can specify locations with different units and measurement systems – we just have to know which to be able to convert.
Name your feature dataset something like “MyFirstFDS”, and Run the geoprocess.
Switch back to the Catalog view (remember, the tab on the lower left on the right third of the program window).

You should now see the MyFirstFDS feature dataset displayed in your Database tree. If not, make sure that the test_gdb_1.gdb is toggled down to display (click on the little triangle, it rotates clockwise when open).

Right click on the MyFirstFDS and select New – Feature Class:
This should open a menu for specifying the location, name, Geometry type, and other options:

Name the feature class “NewLakes”

Specify a polygon Geometry type.

Note that the Geometry Type window has a drop-down menu to specify point, multi-point, polyline, or multi-patch Types.

As described in the textbook, these are different ways of conceptualizing real-world things, and organizing them in a spatial data layer.

Hold the mouse cursor just to the left of the title “Geometry Type”

Note that a small information icon appears. Clicking on the icon will display an explanation banner.

This help is available on most menus.
Accept the defaults for now, and Run the geoprocess to create the new Feature Class.

If successful, you’ve just created a new, empty data set into which you may place data. You usually do this when you create new data, for examples, when you interpret a drone or satellite image, or often when you are modifying old layers and want to keep an original version.

Activate the Catalog, and verify that the NewLakes Feature Class has been created within your MyFirstFDS Feature Data Set.

You may have to expand the list (click on the leading triangle) to see the contents of the MyFirstFDS.

There is nothing to turn in for this section of the lab, but make sure you can successfully create layers with the Catalog tools. We’ll be doing this several times in future labs, and won’t include specific instructions in how to do so in those labs.