LAB 9: Buffering and Overlay in QGIS

What You’ll Learn: to apply the concepts of buffering and overlay, two common cartographic operations. You should read chapter 9 in the GIS Fundamentals textbook.

Data: All data are in L9 subdirectory, including lakes.shp, roads.shp, and public lands in public_Hugo.shp. All distance units are meters.

What You’ll Produce: Three maps, 1) map of lake variable distance buffer zones, 2) map of suitable recreation areas, and 3) map of suitable recreation areas on private land only.

Part One: Buffer Zones
Buffering and overlay are two of the most common operations in cartographic modeling. A buffer zone is an area that is within a given distance from a map feature. When you buffer on a set of features, the output is a set of polygons. (Buffering points or lines creates a new polygon layer). These polygons define an inside region, an area less than the specified buffer distance from the features of interest (e.g., less than 300 meters from a stream), and an outside region, an area more than the specified buffer distance from the features of interest.

These inside and outside regions are typically distinguished by different codes in an attribute table. You should know the specific codes assigned for the software system you use.

Fixed Distance Buffers
A fixed distance buffer applies the same distance for each of a set of features. Fixed distance buffering may be applied to points, line, or polygon input, and creates polygon output.

The figure on the right shows the buffer area (in blue) for a road network (thicker black lines). There will be a corresponding table with some coding to indicate the in/out status of each polygon.

Note there is a third status possible for each polygon. We may note those that are out, but “surrounded” in that they are contained within the bounds of an “in” polygon.
**Variable Buffers**

Another variation on buffering will change the buffer distance depending on feature attributes (see the figure, below).

A GIS project may require buffering those lakes to map a minimum distance from shore for installing septic systems. However, the acceptable distance for septic systems may depend on lake size. A large lake could have a system within 100 meters of lakeshore, but a small lake needs a setback of 25 meters.

A variable distance buffer often uses an attribute that specifies the buffer distance for each feature. You will create a variable distance buffer in this lab, with the buffer distance related to lake size.

The buffering operation typically uses a table entry to determine buffer distance around a feature. A numeric data item is used, as shown in the column named DIST in the table to the right. Each lake with an attribute for surface of 1 will be assigned a buffer with distance 100, a surface value of 2 a buffer distance of 50, and a surface value of 3, a buffer distance of 25. Examples of lakes with the three different surface values and resulting buffers are shown in the figure above.

<table>
<thead>
<tr>
<th>Surface</th>
<th>DIST</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>100</td>
</tr>
<tr>
<td>2</td>
<td>50</td>
</tr>
<tr>
<td>3</td>
<td>25</td>
</tr>
</tbody>
</table>

This item, named dist here, is used to specify the buffer distance.
GIS Exercises

Lab 9: Buffering and Overlay

Part 1: Buffering in QGIS
Create a new QGIS project and add the roads.shp data layer.

Left click on the red Vector (on top tool bar) and select Geoprocessing Tools to then select then Buffer(s) tool. (note: you may need to ensure you have the ftools plug-in activated) (Video: Buffer)

The displayed window (an example in the figure below) allows you to create a buffer layer.

- Set the Input layer to roads.shp
- Specify the Output Features location and name, something like road_buffer_300m.shp.
- Enter the Buffer distance to 300. (The units default to the layer units which in this case are meters)
- Check the Dissolve buffer results
- Check Add result to canvas
- OK.

When the buffering process is finished, it should display the buffer data layer. You should close the ‘completed buffer’ dialog box.

Redo this buffer, but this time; leave the default Dissolve buffer results UNCHECKED. How do the results differ? When would this be important? After inspecting, remove the undissolved layer.

Creating a Variable Distance Buffer
The second exercise will buffer the Lakes.shp layer using a variable distance buffer (Video: Var. Distance Buffer).

The buffer distances are:
- A buffer distance of 50 meters for lakes with size class 1
- A buffer distance of 150 meters for lakes with size class 2
- A buffer distance of 500 meters for lakes with size class 3

This exercise involves three steps:
- First you open the lakes attribute table in QGIS and insert a new field that will hold
the variable buffer distance.
- **Second** you use Select by Attributes to assign the attribute values for the variable buffer distance (refer to Lab 7 if you don't remember the details on selecting and editing values in a table)
- **Third**, you apply the buffer operation.

For our lab, specifically you should:
- Make sure the *Lakes.shp* is in your project, and open the attribute table for *Lakes*.
- Toggle Edit, select New Column, and create a new whole number (integer) field named *buffdist*, with a width of 4.
- Use the **Select Features by Expression** to select each of the lake size classes. Assign the appropriate buffer distance to each lake size class, placing the value in the newly created field. Refer to the Lab 7 in this series if you don't remember how to use the Field calculator to calculate/assign fields.

Close the table. Make sure you unselect any selected polygons, or the buffer will only work on selected polygons (before switching out of the table, click on the Unselect all to clear the selected features. Also make sure you have saved your edits and toggled off the Edit.

Your table should appear similar to that shown below.

Now create the variable distance buffer:
- **Left click in the Vector → GeoprocessingTools → Buffer(s).**
- **Make sure the Lakes.shp layer is Input.**
- **Name the Output Features something logical, such as Var_Lake_Buffer.shp.**
Select the **Buffer distance field** (not Buffer distance) radio button.

Specify the field you created in the previous step, buffdist.

Set the **Dissolve buffer results**

When processing is finished, it should display the buffer data layer; close the Buffer(s) dialog box.

Arrange the roads, dissolved fixed distance road buffer, lakes, and dissolved variable distance lake buffer layers so that you can see all three, as in the figure below.

Create and print/export a layout with the roads, lakes, and their buffers, as in the view shown here. Make sure the order is as shown here, so you may see most of each layer. The order is, from the top, 1) roads, 2) road buffer, 3) lakes, 4) lake buffer.

Your data view should look something like the figure at right.

Create a layout, and label each layer with descriptive text in the TOC/legend, and include a scale bar, north arrow, and title.
GIS Exercises

Lab 9: Buffering and Overlay

**Part Two: Overlay in QGIS**

Overlays are another common operation. An overlay is the primary way to combine information from two separate themes. Overlays are most common for polygonal data, and perform a geometric intersection, which results in a new layer with the combined attributes of both initial layers.

Our goal in this exercise is to find potential campgrounds for a State Park. A campground needs to be close to lakes. However, these will be ‘drive in’ sites and they must also be close roads. The final map will show locations that are both within 50, 150 or 500 meters of a lake (depending on the size of the lake) and within 300 meters of a road.

We have already created our starting Layers. These are the variable distance lakes buffer, and the fixed distance roads buffer from the previous exercise.

In QGIS we must modify input layers prior to overlay so that we may easily interpret the results after overlay. We add a field to each input data layer that specifies the factors we wish to use later in our analysis.

In our current exercise, we wish to identify areas that are inside the lake buffers. We create a new item (column) in the lakes buffer table, name it something like insd_lbuf, and give it a value of 1 for all the lake buffer polygons (you should know how to do this by now, without step-by-step instructions, but refer to previous labs, or ask the instructor). When you are done, you should have an attribute table for the lakes buffer that looks like:

Do the same for the road buffer layer. Add a new attribute named something like insd_rbuf, and assign it a value of 1 to indicate it is inside the road buffer. Remember to un-toggle Edit for each layer when complete.

We don’t worry about assigning a value for areas outside the buffer in this exercise, because of the way QGIS views the vector world. Areas outside of polygons do not have a boundary nor a record in the attribute table associated with them. We cannot assign a value for these “outside” areas in each input layer, because there is nothing to attach the value to. Some other vector GIS packages define a bounding polygon for the outside world, and in a later lab we will use raster overlay to assign values for both the inside and outside areas. We usually do not assign “outside” areas in vector overlay in QGIS.
Before we overlay the two layers with the “Union” command, we need one more preparation step. The lake buffers layer we created has buffered areas that include the lake as well as the land near shore. We only want campsites on dry ground, so we will “erase” the lake from the lake buffer layer.

First, open the Vector ➔ Geoprocessing Tools ➔ Difference
- Specify Input Vector Layer as the variable lakes buffer layer
- Specify the Difference Layer as the lakes layer
- Set the output destination to outside_lake_buffer.shp
- OK to apply the buffer
- Close when complete

![Image of Difference dialog box]

Add the outside_lake_buffer.shp to your QGIS project.

Once you’ve erased the lakes from the lakes buffer layer, the final step is to overlay the two buffer layers (Video: Union).
- Select Vector ➔ Geoprocessing Tools ➔ Union
- Specify the input layers – outside_lake_buffer and road_buffer_300m.
- Specify the output layer Union_Lk_Rd.
- Press OK.

Examine the “unioned” layer and open the attribute table for this layer. Select the polygons that meet both the within the roads buffer and the within the lakes buffer criteria (see the figure below for some hints).

Note the number of records selected.

Why do you have only 3 records? You can see more polygons on the screen.

QGIS groups polygons in the data files when performing analysis. When we are finished with our analysis we will “ungroup” polygons in the file, creating a table row for each polygon.

Open the attribute table for the Union_Lk_Rd.shp and create a new field named something like in_both to identify those areas that meet both the inside road buffer and inside lake buffer criteria (refer to previous exercises).
Use **Select by expression** to find those areas with insd_lbuf=1 and insd_rbuf = 1, and assign them the number 1 using the **Field Calculator** assign then to a field called “in_both” (previous exercises, or see graphic below).
Close the attribute table, make sure the Union_Lk_Rd layer is selected and right click on the layer name in the TOC. Right click on the Union_Lk_Rd layer in the table of contents, and select **Save As → ESRI shapefile** and save only the selected (where in_both =1) to a file called **Acceptable_Areas**.

Select **Vector → Geometry Tools → Multipart to singleparts**. (Video: **Multipart**). This will ungroup the combined polygons to and create a row in the attribute table for each polygon. You should have 32 records in the table for the singlepart file.

Display the *roads*, singlepart *acceptable areas*, and *lakes* in the view. It should look something like the figure at right.

Now before you print/export the map you need to determine the size (in acres or hectares) of your acceptable sites. (Video: **Area**).

Open the attribute table, toggle edit and add a float or double field named "Hectares" with a precision of at least 12, scale of 1 or 2. Verify that there are 32 records in the table.

Use the Field Calculator to assign the Expression $\frac{\text{area}}{10000}$ to the existing field called Hectares. There are 10,000 sq. meters in a hectare. The $\text{area}$ function returns the area of the polygons measured in square meters; (how do you find this out? Check Layer Properties, General, Coordinate reference system, Selected CRS; eg. +units=m)

The new Hectares column should be populated with numbers, with values between 0 and 300.

Remember to toggle off the Edit button to save your work.
Right click on the Statist button:

As show use Hectares as your Target field and click OK

Count should be 32. If it isn’t, perhaps you selected the wrong layer, or made a mistake in the processing chain.

The total area should be over 1000, but below 1200. If it is way off, perhaps you selected incorrect units in calculating geometry.

Create a second .PDF as show to the right.

Add the hectares measurement to the map.
PART 3 Estimate the amount of Private (non-public) land in your proposed Campsites locations.

Create a new or add to existing project layers roads.shp, Lakes.shp, Single_part_Acceptable_Areas.shp, and Public_Hugo.shp (see figure below).

Open the Vector- > Geoprocessing Tools → Difference

- From the Single_Acceptable_Areas layer, use the Public_Hugo as the difference (Erase) this removes the publicly owned land in Hugo from your Acceptable Areas.
- Name your new layer; in the Output Feature Class to ‘Campgrounds_on_Private_Land’. This is the land that would need to be acquired if the community wants to build campsites.

Recalculate the area of Campground_on_Private_Land and note it size in hectares. Subtract it from your previous area calculation (the total Acceptable Areas from Part 2).

Create a Layout that includes roads, lakes, and Campgrounds_on_Private_Land. (see below).
Label each layer with descriptive text in the legend, and include a scale bar, north arrow, and title.

Make sure you add the area measurement of the suitable for campground on private land, in hectares.

Print or Export a map from this layout, your third and final map for this lesson.

**MAPS TO TURN IN:**
- Hugo, MN Lake and Road Buffers
- Hugo, MN Areas suitable for Campground
- Hugo, MN Areas suitable for Campground (Private land only)